Apache Hive

  • 时间:
  • 浏览:0
  • 来源:uu直播快3平台

https://issues.apache.org/jira/browse/HIVE-11920

hive-2.0.0-apache,

hive-1.1.0-apache,

5.Compile hive-1.2.1

3.Patch HIVE-11920.1.patch

Format: patch -p0|-p1 < xxxx.patch

可能使用参数-p0,就表示从当前目录,找另4个 叫作b的目录,在它下面找另4个 叫ql的目录,再在它下面找另4个 叫src的目录。

6.Upload mysql-connector-java-5.1.36-bin.jar 

7.Modify hive-site.xml

4.Download maven tool and configure parameter

:

Bug1:ADD JAR failing with URL schemes other than file/ivy/hdfs

可能使用参数-p1, 就表示忽略第一层,从当前目录找另4个 叫ql的目录,在它下面找另4个 叫src的目录。原先会忽略掉补丁头提到的b目录。

2.Download patch

hive-1.1.0-cdh5.4.8等版本与Apache hadoop2.7.2与脚本内容兼容错误甚多,且尝试无法避免,于是选泽hive-1.x.x系列的最新版。

8.Rerun tar hive files

1.Download hive-1.2.1 source code

其中亲戚亲戚大伙儿尝试了以下 

hive-1.1.0-cdh5.8.0,

可能完后 使用CDH5.4.8,其Hive版本为1.1.0,其业务的脚本和jar也在此版本开发,全都有全都依赖性,兼容性等等。有些当亲戚亲戚大伙儿计划将CDH5.4.8 Job迁移至AliYun EMR平台上,发现hive-1.1.0-cdh5.4.8与该平台的Apache Hadoop2.7.2 严重只能兼容,于是花了很长时间在做这件事--根据业务脚本和jar包定制亲戚亲戚大伙儿的hive-1.2.1-emr版本